Archive: ‘UPM’ Category

UPM using 100% cpu

1 comment October 8th, 2010

I have seen the UPM taking 100% cpu a few times, or taking 100% cpu from one core as its not multi-threaded. In all of the cases a corrupt UPM cache file was the problem. Its located in C:\Program Files\Citrix\User Profile Manager and called “UserProfileManager_C.cache”. I just deleted it and restarted the UPM service and problem solved.

Im thinking of making a policy that deletes that file on every reboot as its only a cache file and it wont make a difference if its not there when the UPM starts, as it creates a new one when it needs it.

Citrix on VMWare

No comments October 8th, 2010

I ran into a problem with one of my servers on vmware the other day. HGFS, vmware shared folders, was activated for some reason. The symptoms was that the desktop background image disappeared after each log off which made the user always get a black background every time he logged on. I also noticed that it never deleted any profiles from the server. So when you logged on it just created a new one like user.dom.000 and next time user.dom.001 and so on. To diagnose the problem i turned full logging on in the UPM. I found this:

DeleteAnyFile: Deleting the file <C:\Users\user.dom.013\AppData\Local\VMware\hgfs.dat> failed with: The process cannot access the file because it is being used by another process.

I started google it and found this. Which says how to disable hgfs through the registry.

In the registry find the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order\ and edit ProviderOrder. Remove hgfs from there and reboot the machine.

After this everything worked perfect.

Xenapp 6 reboots and UPM 3 troubles

No comments September 16th, 2010

Ever since xenapp 6 was released there have been a problem with servers not been able to reboot. Theres a big thread about it over on the citrix forums. The problem was first reported the 14th of april and now its in the middle of september. They must have lots to do overethere as the patch hasnt been released yet! Its coming, finally, tomorrow! This is awesome. Then i can start to reboot my servers again automatically everynight instead of manually rebooting them every now and then.

Ive been having some trouble with the user pofile manager leaking memory. Its UPM 3.0 and the current version is 3.2 where the memory leak has been fixed. I havnt upgraded thou because im using streaming profiles which for some reason dont work if i upgrade. But because i cant reboot the servers every night the UPM process has been growing everyday and in some cases been causing trouble. Thou ive been told on the forums it could have somethign to do with Trend Officescan. I really like the streaming profile feature because of fast logon times which is why i havnt upgraded all servers, had to upgrade a few and turn the feature of thou.

So my next mission is to patch all the servers with Hotfix XA600W2K8R2X64003 to be able to reboot the servers, then see if i can get the streaming profiles running without Officescan! Dont know if it will be worth running without antivirus thou.